OpenRoads Designer CONNECT Edition SDK Help

CreateTangentToLineThruPoint Method

Constructs Spirals tangent to line and passing thru a point

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  LinearElement[]CreateTangentToLineThruPoint( Line backLine, DPoint3d thruPoint, SpiralType spiralType,double spiralParam,double spEndRadius)

Parameters

SettingDescription
  Line Back Line.
  DPoint3d Thru Point.
  SpiralType Spiral Type.
   Spiral Parameter.
   Spiral End Radius.

Return Value

LinearElement[]

See Also